El parche 1.12 de Cyberpunk 2077 soluciona la vulnerabilidad de ejecución de código remoto

El parche 1.12 de Cyberpunk 2077 soluciona la vulnerabilidad de ejecución de código remoto

por Jordi Bercial ...

Recientemente hablábamos de que se había descubierto una vulnerabilidad en Cyberpunk 2077 que podría permitir a un atacante a través de los mods del juego ejecutar código malicioso de forma remota, algo que bien por una parte podría causar problemas en forma de malware directo, o que también podría provocar que se abriese una puerta a malware de mayor escala, como un ransomware.

En cualquier caso, tal como podemos ver en la cuenta de twitter oficial del juego, CD Projekt RED ha solucionado los problemas que causaban esta vulnerabilidad, que, si bien principalmente existía en algunas DLL existentes en el juego que han sido reemplazadas o directamente eliminadas, también existía un problema relacionado con el búfer que formaba parte de esta vulnerabilidad.

En cualquier caso, con la instalación de la versión 1.12 del juego, deberíamos poder utilizar mods de terceros sin tener que preocuparnos de nada, de forma que podemos levantar la “restricción” de utilizar solamente nuestros propios mods o mods de gente que conozcamos y, ahora sí, podremos utilizar cualquier mod que podamos encontrar en Internet.

Cabe destacar que, si bien esta vulnerabilidad está solucionada, nada impide a un atacante intentar utilizar los clásicos métodos de infección como adjuntar ejecutables que el usuario deba abrir manualmente, por lo que siempre tenemos que ir con cautela a la hora de descargar archivos de Internet.

Fin del Artículo. ¡Cuéntanos algo en los Comentarios o ven a nuestro Foro!

Redactor del Artículo: Jordi Bercial

Jordi Bercial

Ávido entusiasta de la tecnología y la electrónica. Cacharreo con componentes de ordenador casi desde que aprendí a andar. Empecé a trabajar en Geeknetic tras ganar un concurso en su foro sobre redacción de artículos de hardware. Amante del Drift, la mecánica y la fotografía. No te cortes y deja un comentario en mis artículos si tienes alguna consulta.

Comentarios y opiniones sobre: El parche 1.12 de Cyberpunk 2077 soluciona la vulnerabilidad de ejecución de código remoto ¿Qué opinas? ¿Alguna pregunta?